Condition laat alles verdwijnen/werkt niet

Dit forum is bedoeld voor vragen met betrekking tot WYSIWYG Web Builder.
Post Reply
Jorus
 
 
Posts: 145
Joined: Mon Jan 04, 2016 1:39 pm

Condition laat alles verdwijnen/werkt niet

Post by Jorus » Wed May 15, 2019 2:51 pm

Ik heb binnen een Layer (tevens Form), een Editbox met als Condition bij Change > Hide van een ander Editbox (heb ook andere objecten geprobeerd) Echter verschijnt de te Hiden Editbox helemaal niet nog voordat ik iets Change.

Bij de Condition> Action> Show van het Editbox verschijnt het Editbox eveneens niet.

Is dit eenvoudig te verklaren?

User avatar
Pablo
 
Posts: 15941
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Condition laat alles verdwijnen/werkt niet

Post by Pablo » Wed May 15, 2019 2:56 pm

Merk op dat 'onchange' alleen wordt getriggerd als je de editbox verlaat.

Om je hierbij te kunnen helpen moet ik precies weten wat je hebt gedaan.

Zie ook:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

Jorus
 
 
Posts: 145
Joined: Mon Jan 04, 2016 1:39 pm

Re: Condition laat alles verdwijnen/werkt niet

Post by Jorus » Sun May 19, 2019 12:35 pm

Link website
https://link verwijderd

Link wbs file
https://link verwijderd
Last edited by Jorus on Tue May 21, 2019 1:36 pm, edited 1 time in total.

User avatar
Pablo
 
Posts: 15941
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Condition laat alles verdwijnen/werkt niet

Post by Pablo » Sun May 19, 2019 12:53 pm

De logica van de conditions is niet juist.
Je hebt de button nu via de Object manager verborgen (= CSS), dit moet ook via conditions (= JavaScript).

Jorus
 
 
Posts: 145
Joined: Mon Jan 04, 2016 1:39 pm

Re: Condition laat alles verdwijnen/werkt niet

Post by Jorus » Sun May 19, 2019 1:16 pm

Ik heb de button1 (via de opbject manager) weer zichtbaar gemaakt, en via het venster de condition ingesteld op "is empty >hide>button1" Dat werkt niet.. de button1 blijft van begin af aan zichtbaar. Ik heb tevens de condition/help gelezen maar zal iets niet hebben gegrepen? :roll:

User avatar
Pablo
 
Posts: 15941
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Condition laat alles verdwijnen/werkt niet

Post by Pablo » Sun May 19, 2019 1:55 pm

Sorry, maar de logical is niet juist.
Het 'onchange' event wordt altijd aangeroepen, omdat anders de berekening niet tijdens het laden van de pagina zou worden uitgevoerd.

Jorus
 
 
Posts: 145
Joined: Mon Jan 04, 2016 1:39 pm

Re: Condition laat alles verdwijnen/werkt niet

Post by Jorus » Sun May 19, 2019 2:30 pm

Dank voor je feedback. Ik begrijp nu wat 'change' exact inhoud en heb deze vervangen voor 'greater than'. Alles werkt nu naar behoren.

Post Reply