[Solved] Overlay menu creates invalid HTML code

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Post Reply
Transcendence
 
 
Posts: 9
Joined: Tue Jun 26, 2018 4:32 pm

[Solved] Overlay menu creates invalid HTML code

Post by Transcendence » Tue Jun 26, 2018 4:44 pm

Hi,

I am trying an overlay menu and find this code as a result in the created HTML page (WB 14.05):

Code: Select all

<div id="masterOverlayMenu1-overlay">
<div class="masterOverlayMenu1">
<ul class="drilldown-menu" role="menu">
<li>
<a role="menuitem" href="#">L&#214;SUNGEN</a>
<ul class="drilldown-submenu" role="menu">
<li><a role="menuitem" href="./index.html#indexTopOfPage"">Darum&nbsp;geht&nbsp;es</a></li>
<li><a role="menuitem" href="./index.html#tasks"">Was&nbsp;m&#246;chten&nbsp;Sie&nbsp;anpacken?</a></li>
<li><a role="menuitem" href="./index.html#portfolio"">Das&nbsp;k&#246;nnen&nbsp;wir&nbsp;f&#252;r&nbsp;Sie&nbsp;zun</a></li>
<li><a role="menuitem" href="./index.html#trainingcourses"">Offene&nbsp;Weiterbildungen</a></li>
</ul>
</li>
All menu subitems contain "" (= two times " instead of one closing ") at the end of the href declarations. This is invalid code that html vacidators find fault with, also Firefox does so in the source text view. As search engines like valid code, this may lower the website ranking.

This seems to be a bug. Can it be fixed?

Thanks in advance for looking over it
Frank
Last edited by Transcendence on Tue Jun 26, 2018 7:20 pm, edited 1 time in total.

User avatar
Pablo
 
Posts: 14032
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Overlay menu creates invalid HTML code

Post by Pablo » Tue Jun 26, 2018 5:25 pm

Thanks for the information.
The problem has been fixed in the latest build (6/26/2018)

Transcendence
 
 
Posts: 9
Joined: Tue Jun 26, 2018 4:32 pm

Re: Overlay menu creates invalid HTML code

Post by Transcendence » Tue Jun 26, 2018 6:43 pm

Yes, now it works. Great, thanks! :D
Frank

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests