z-index problem in Carousel in full width mode

Issues related to previewing and publishing your web site.
Post Reply
mckonen
 
 
Posts: 33
Joined: Sun Mar 20, 2016 6:59 pm

z-index problem in Carousel in full width mode

Post by mckonen » Mon Sep 16, 2019 6:57 pm

Hi, noticed that z-index order not working in Carousel when set it to full width mode, Carousel is in front of everything, in full width set to "none" everything works fine. Nothing helped within the WB15, but by adding this style="position: relative; z-index: 2;"> after the <div id="wb_Carousel1"> with notepad fixed this issue, so: <div id="wb_Carousel1" style="position: relative; z-index: 2;">.
Not the big issue, but just wonder is this a bug or not...

User avatar
Pablo
 
Posts: 18940
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: z-index problem in Carousel in full width mode

Post by Pablo » Mon Sep 16, 2019 8:22 pm

This is expected behavior because in order for the Carousel to be full width, it must be outside the body container and therefor it it will be added at the end of the HTML.
So, the z-index does not have any effect relative to the rest of the content.

mckonen
 
 
Posts: 33
Joined: Sun Mar 20, 2016 6:59 pm

Re: *** NOT A BUG *** z-index problem in Carousel in full width mode

Post by mckonen » Fri Sep 20, 2019 7:54 pm

Yes, the Carousel is in the end of the page, but just wonder that this same z-index value can be add in the objects - custom style html in the WB, but not working even though is the same code as the manually edited and it works right, very weird in deed...

and noticed the position must be set to absolute the work properly.

Post Reply