Page 1 of 1

*** SOLVED *** Issue with Creating Folders on Server

Posted: Sat Nov 23, 2019 1:26 pm
by presto
I have added a new folder with a certain number of subfolders to a project via the Site Manager of WWB 15.2.0
In preview these folder and subfolders are created. But when publishing to my server the folders are not created i.e. they do not exist.
I publish my website with SFTP

Re: Issue with Creating Folders on Server

Posted: Sat Nov 23, 2019 3:53 pm
by Pablo
A folder needs at least one file to be created. Empty folders will be ignored.

Re: Issue with Creating Folders on Server

Posted: Sun Nov 24, 2019 10:52 pm
by presto
Pablo wrote:
Sat Nov 23, 2019 3:53 pm
A folder needs at least one file to be created. Empty folders will be ignored.
Is this behavior really neccessary? Is there a serious reason for this?

I politely ask this question since I wanted to publish 12 empty folders in order to fill them with images for 12 Slide Shows that should get images from a folder on the server. I want to fill these folders step by step on a daily basis with pictures from a trip just from outside WWB. Now I had to do the trick using the build-in file publisher which works fine with empty folders.

I ask this question since it is possible to publish empty folders to a local folder from within WWB. So why does it make sense to surpress this when publishing to a server instead to a local folder?

Re: Issue with Creating Folders on Server

Posted: Mon Nov 25, 2019 6:53 am
by Pablo
It is related to how the Secure FTP protocol works. Unfortunately, it works completely different than normal FTP.
But I will investigate if I can find a workaround to make it possible in the future.

Re: Issue with Creating Folders on Server

Posted: Mon Nov 25, 2019 12:08 pm
by presto
Thanks for clarification and your efforts. I am sure there will be a solution for this since it is possible to publish empty folders via the file publisher and Secure FTP without any problems. But doing this via the object manager would be a more elegant and convenient solution.

Re: Issue with Creating Folders on Server

Posted: Tue Dec 10, 2019 1:31 pm
by presto
12/10/2019 - Version 15.2.x (hot fix)
- Fixed: Issue with alignment in Themable menu.
- Fixed: Server sided form validation does not throw exception.
- Improved: Added support for empty folders in FTP/SFTP engine.
- Improved: 32bit version now includes '32-bit' in window title and aboutbox.

Thank you so much, Pablo.Love you. :lol:

Still existing: Issue with Creating Empty Folders on a Server

Posted: Wed Dec 11, 2019 3:32 pm
by presto
I am sorry to inform you that publishing of empty folders that are inserted into the site manager still does not work although it should in the latest version according to this:

12/10/2019 - Version 15.2.x (hot fix)
- Fixed: Issue with alignment in Themable menu.
- Fixed: Server sided form validation does not throw exception.
- Improved: Added support for empty folders in FTP/SFTP engine.
- Improved: 32bit version now includes '32-bit' in window title and aboutbox.

May be I have this information misunderstood or do I make something wrong?

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 4:17 pm
by Pablo
What exactly did you do?

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 5:23 pm
by presto
Inside the Site Manager I inserted an empty folder, then I tried first to publish this folder separately via SFTP, then I published the whole site. In both cases the empty folder was not published on the server. When publishing to a local folder on my pc then the empty folder is published.

Empty folders can be published via FileZilla and SFTP without any problem, so it seems not being depending on settings of the server.

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 6:02 pm
by Pablo
I don't think you can just publish an empty folder. But it will be included if you publish the entire website. For me, it works with workaround in the latest build.
If not, then I need a demo project and a description what you have done to make it not work.

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 6:05 pm
by presto
Maybe for clarification I should add that the empty folder(s) are not subfolders to a page but are on the same level as pages. I will send an example project per e-mail to you.

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 7:03 pm
by Pablo
I have tried your project and it works for me. I have tried on 3 different Secure FTP servers, including FTP with TLS/SSL.

Are there any errors in your publish log?

Re: Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 7:04 pm
by presto
Now it works, please stop searching. Most probably I had the wrong link on my pc's desktop to the old version of WWB 15. I am deeply sorry for having made such trouble.

Re: *** SOLVED *** Issue with Creating Folders on Server

Posted: Wed Dec 11, 2019 9:34 pm
by Pablo
Ok, thanks for clearing that up.

The good thing is that I have now tested on a few extra servers, so I'm more confident that it works correctly;)