Captcha not authenticating

Issues related to forms.
Post Reply
Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Captcha not authenticating

Post by Hbrownell » Thu Mar 04, 2021 10:46 pm

I set up captcha to eliminate some spam I've been getting. However, when I try to test the captcha out on my sandbox, it fails even though the correct letters are in the box. Can someone look at it and see if I missed a beat somewhere? Thanks!

http://www.henrisandbox.com/Files/TEST.wbs

User avatar
crispy68
 
 
Posts: 1396
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: Captcha not authenticating

Post by crispy68 » Fri Mar 05, 2021 12:03 am

Are you uploading the page all the files to test? It wont work in preview.

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 1:06 am

It's just a link to the file.

User avatar
Pablo
 
Posts: 23391
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Captcha not authenticating

Post by Pablo » Fri Mar 05, 2021 7:08 am

The form seems to be correct.
What is the URL of the page, so I can see the error message?

Note that the captcha is case-sensitive

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 2:38 pm


Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 3:00 pm

I turned off "Enable real-time validation through AJAX" and now it seems to allow the message to run its' course. Now I'm not getting the messages in my email.

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 3:09 pm

It's also not going to either a fail or success page now. grr..

User avatar
Pablo
 
Posts: 23391
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Captcha not authenticating

Post by Pablo » Fri Mar 05, 2021 3:16 pm

I turned off "Enable real-time validation through AJAX" and now it seems to allow the message to run its' course./quote]
In that case, your website may not support AJAX or the AJAX script is not on the server.

Your test project does not have a success and error page so I cannot verify the settings for that.

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 3:47 pm

I put one in there. I resent the file. What's funny is I see your test from earlier 9:15am (my time). I haven't been able to do that from my end..

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 4:16 pm

So, brave browser seemed to work, but both chrome and firefox failed..

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 4:30 pm

I think I need to start over here.

You see the form I'm trying to create.
I want to have it reply with an autoresponder message that captures the email of the user that sent in the request. (Basically so it captures both incoming and outgoing for redundancy)
I thought I read that I needed to set up an SMTP account for that, which I did. But, it doesn't seem to work with the login credentials. I can log into the account and I copy/paste those credentials to the form but still fails. (for the mail engine)

What am I missing?

User avatar
Pablo
 
Posts: 23391
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Captcha not authenticating

Post by Pablo » Fri Mar 05, 2021 4:43 pm

I do not think that the browser will make any difference. The form is processed on the server side.

Whether or not you need SMTP depends on the configuration of the server.
If SMTP is required , then you will need to enter the SMTP information of the server.

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 4:46 pm

But will setting up SMTP allow me to capture the email on a reply? (using the auto reply built into the form)

I turned off SMTP and got both firefox and brave to correctly send the forms to my email, however neither of them captured the outgoing reply and chrome is still failing. This is the only information I can find that comes close to what I'm dealing with, but I don't know PHP, so I don't know if this is relevant with your code.

https://stackoverflow.com/questions/318 ... validation

Hbrownell
 
 
Posts: 75
Joined: Fri Dec 06, 2019 3:58 pm

Re: Captcha not authenticating

Post by Hbrownell » Fri Mar 05, 2021 5:09 pm

Okay, so I rebooted my computer and now magically chrome works. (Google really pisses me off at times) So, I'm back to trying to move forward with the SMTP. Provided that I hear from you that it's going to do what I need it to do. (Capture the email out the outgoing messages sent via the auto-reply)

User avatar
Pablo
 
Posts: 23391
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Captcha not authenticating

Post by Pablo » Fri Mar 05, 2021 6:05 pm

Please see "Emails are not arriving in my inbox":
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=32967

If that does not help then you will need to ask your webhost why the emails are not sent.
Based on their feedback you can then modify the settings of your form.

Post Reply