Hoverbox Image Gallery ***Updated 07/04/12****(Unavailable)

In this section you can share self-made extensions with other users of WYSIWYG Web Builder.

There are already more than 250 extensions available!
User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sat Apr 25, 2009 6:51 am

Don't you have a template ? I don't get it.

Do i have to wrote an external file with all the html data or what?

I feel quiet stupid not understanding the pdf file.

The thing is if i put in a image i don't get an image at preview.

I don't get it why


Found it..... I forgot the image id....... oeps
Last edited by neo_webbuilder on Sat Apr 25, 2009 2:46 pm, edited 1 time in total.

User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sat Apr 25, 2009 7:47 am

Please modify the z-index..... to 3000 or up. The image dives behind the menubar if the hoverbox is put above a menu bar !!!

The same problem as with the lightbox

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sat Apr 25, 2009 11:00 am

What has this to do with extension??????
Quote:
Write here your text ,images and urls in plain text or html.
Image code: <img src="http://www.domain.com/image.jpg">
Images folder code: <img src="images/image.jpg">
Images folder code: <img src="http://www.domain.com/images/image.jpg">
Url code same window: <a href="http://www.domain.com/index.html" target="_self">click here</a>
Url code new window: <a href="http://www.domain.com/index.html" target="_blank">click here</a>
New textline: <br>
Bolt text: <b>your text</b>
Text center: <center>your text</center>


Don't you have a template ? I don't get it.

Do i have to wrote an external file with all the html data or what?

I feel quiet stupid not understanding the pdf file.

The thing is if i put in a image i don't get an image at preview.

I don't get it why


Found it..... I forgot the image id....... oeps

User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sat Apr 25, 2009 2:45 pm

What has this to do with extension??????
Didn't know you.ve got angry...... I sais in the last sentence i found it..... it was my own mistake......

But please modify the z-index of the extension to above the menubar z-index..... otherwise the hoverbox photo will appear underneath the menubar if the hovebox is placed some where above the menubar.

User avatar
Eddy
 
 
Posts: 477
Joined: Tue Nov 27, 2007 1:52 am
Location: Nederland.

Post by Eddy » Sat Apr 25, 2009 4:05 pm

Please modify the z-index..... to 3000 or up.
menubar have Z_index 2000
lightbox have now Z-index 2999

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sat Apr 25, 2009 11:05 pm

neo_webbuilder me angry noooo sorry if it looked like that just asking what you were refering too thats all anyway new download available from first post added to the extension two variables for z-index as you requested done it this way so users can set z-index to what they need instead of having fixed in css file reason for two is one fix's IE the other is just for normal use of css

User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sun Apr 26, 2009 7:43 am

BaconFries wrote:neo_webbuilder me angry noooo sorry if it looked like that just asking what you were refering too thats all anyway new download available from first post added to the extension two variables for z-index as you requested done it this way so users can set z-index to what they need instead of having fixed in css file reason for two is one fix's IE the other is just for normal use of css
Wow Thanks mate !!!

First and second... it was my own stupidty not understanding that i had to link the original image id-frame to the hoverbox...... The pdf was not idiote proof i guess.

About the container...... I was wondering why not create a container in which you can just select the images as in the lightbox....... Although the hoverbox also works on text.....

Maybe its an idea for a new extension the image hoverbox... Just for images as the lightbox container.

I love this one found out that xhtml is required otherwise you get the yellow (or whatever color set) backgound banner. It was all in the pdf but sometimes reading seems to be difficult. Or maybe reading and understanding what the author wants to tell you.

User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sun Apr 26, 2009 7:44 am

The download link rapidshare is limited to 10 times. I cannot download the updated file.

***** rapidshare anyway #$%$$@!%@%

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Apr 26, 2009 12:24 pm

I hate rapidshare myself for this but at the time of posting mediafire was down, or was up but not accepting uploads it back to normal so new mediafire link available in original posting. I will take a look at trying to impliment lightbox but the if you look at it it would just be another lightbox but I will look into it....

User avatar
neo_webbuilder
 
 
Posts: 82
Joined: Wed Jan 31, 2007 11:05 am

Post by neo_webbuilder » Sun Apr 26, 2009 2:07 pm

What happened to the hoverbox tooltip extension?

Could you please adjust the hoverbox tooltip with the z-index?


May i give some feedback to the gallery?
Further more i implemented the hoverbox gallery but i ran into a problem.

1. What if i don't have 20 pictures? I get the windows with the red cross in it.
2. Please keep aspect ratio in the hover over. Now the photo is stretched. This is not nice when the photo is not square in size.
3. is it possible to give the direction of the hover window. Starting at Left uppercorner down or right left conner at the bottom and then upwards left etc. etc. etc.

Keep up the good work
Neo_webbuilder

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Sun Apr 26, 2009 2:41 pm

Ok the script I used was designed for twenty images so I just kept it to that..I did try to build it so user could insert as many or as little images as they choose to do so but it spoiled the layout and didnt function properly as it should. Now dont take this the wrong way I am no coder I only take what is available and make the best of it or try to make best of it to make it simpilar for users to add scripts to the pages without having to manually do so. You asked about the Hoverbox tooltip extension this was made by Eddy you can ask him if he can make the changes you need.
Answers to your questions
1.As I said the original script used twenty images so I just kept it that way you could manually remove any image holders you dont want from html I know it not want you want but it a solution.
2.Again with the original script it used a fixed height and width in css for thumbs 100x75 and a set height width for mouseover (preview)200x150 in css. It also used images that were of all the same size ie 200x150 landscape for both thumb and mouseover All I can sugest is you do not used portrait and landscape images in same gallery or you make all images the same size this will help to sort any distorting.
3.No I dont think this is possible as it wasnt part of the original script and as I said I am no coder so I wont be able to implement this sorry.

As always if I can help I will but if the script has limitations there really not much I can do...

rvanveen
 
 
Posts: 11
Joined: Wed Jan 14, 2009 9:58 pm

***Updated 26/04/09**** Hoverbox Image Gallery

Post by rvanveen » Fri May 08, 2009 3:16 pm

Is it correct/normal that you cannot have the usual browser preview, but that you can only see the results after publishing to a site?

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Fri May 08, 2009 3:49 pm

No you should be able to preview by press F5 on keyboard or by going to File\Preview In Browser\Default Browser this should open like this
C:\Documents and Settings\JustMe\Local Settings\Temp\preview\index.html

rvanveen
 
 
Posts: 11
Joined: Wed Jan 14, 2009 9:58 pm

***Updated 26/04/09**** Hoverbox Image Gallery

Post by rvanveen » Fri May 08, 2009 4:35 pm

OK, found that.
Now I am playing with a website in which all pages have a width of 800: I notice that the hoverbox (can check by changing its background color) nevertheless takes the full width of my screen and moreover it hides behind all other elements on the page.
I did a 'move to front' zillion times; changed the size of the hoverbox in its properties several times, but all in vain. What am I doing wrong here?

User avatar
BaconFries
 
 
Posts: 4829
Joined: Thu Aug 16, 2007 7:32 pm

Post by BaconFries » Fri May 08, 2009 5:00 pm

Have you used the Z-Order settings within the extension or are you using WB to set the z-order. In the extension you need to set both z-orders to a higher setting try setting each of the z-order to say 3000. If you still have a issue I will look into it......

Post Reply