Google Maps API v3 ***Re-Released 17/07/2014*** (Deprecated)

In this section you can share self-made extensions with other users of WYSIWYG Web Builder.

There are already more than 250 extensions available!
User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 24/04/11***

Post by BaconFries » Tue Jun 07, 2011 8:13 pm

Ok I will post a link later for you to grab a selection of map icons that you can use on the map...:)

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Tue Jun 07, 2011 9:45 pm

***Update 07/06/11***
Link added for Google map markers added please see first posting

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Wed Jun 08, 2011 8:44 am

Hi BF,

I think we all owe you a huge debt of gratitude for this superb extension.

Thanks for all your hard work, it's very much appreciated.

Steve

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Thu Jun 09, 2011 5:27 pm

BF, can I ask your valued opinion?

If you get a minute take a look at my two (Web Builder 7 Created) sites..

http://www.thecroftcottage.co.uk
http://www.theoldchapel.co.uk

When I look with IE9 at the "Map of the Area" page (on both sites) and then click the "marker" - the text font in the "info window" seems slightly different between my two sites!!
The text font etc should be identical as I set Arial 12 in the GM extension for both maps and all the other settings are identical?

If I look with FF4 there seems no difference?

Can you see any reason why this may be happening?

Steve

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Thu Jun 09, 2011 5:34 pm

This is because IE9 is using hardware-accelerated text using sub-pixel Microsoft ClearType font positioning. This will make the font you used look different in display compared to older versions of IE you can trying
Page properties>Misc>Compatibilty>Emulate IE this should force it to look how it should. You can also read more on hardware-accelerated text below..
http://msdn.microsoft.com/en-us/library ... s.85).aspx

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Thu Jun 09, 2011 5:37 pm

Thanks but it can't be that as I've disabled that using the following files
http://www.softwareninjas.ca/dwrite-dll-wrapper

But it wouldn't explain why both info texts look slightly different in IE9 as they're using the exact same settings - surely they should look identical?

It's only me being V picky :-)

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Thu Jun 09, 2011 6:32 pm

I take a look and see why this maybe happening looking at my extension it could be due to the wrong doctype getting outputted...this is only something I can fix...I will also add compatibilty mode to the extension as well to allow emulation for older browsers...

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Thu Jun 09, 2011 6:40 pm

Oh and the only other thing I noticed is that if you add an apostrophe to text in an info window - that webpage won't then load

BTW Please don't think I'm being critical because I'm not!!

Your extensions ROCK!

Steve

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Thu Jun 09, 2011 8:05 pm

Ok to over come this we need to do add this ’in place of the '
For example:
Mrs. Lewis ' s car is nice.
becomes below but will render/display correctly when published/previewed
Mrs. Lewis’s car is nice.

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Thu Jun 09, 2011 9:02 pm

As ever - thanks for the quick answer :-)

Steve

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Mon Jun 20, 2011 9:05 am

Just one last question BF..

...and apologies if this has been asked before..

Is it possible to have the balloon tip show when the map loads instead of having to click on the marker..

Steve

harrismail
 
 
Posts: 22
Joined: Tue Jun 02, 2009 8:36 am

Re: Google Maps API v3 ***Update 07/06/11***

Post by harrismail » Tue Jun 21, 2011 4:35 pm

and also besides the question above do you know why when someone clicks on my streetview link for the first time (contained inside the info balloon) at http://www.theoldchapel.co.uk choose The Old Chapel and then "Map of the Area" page - click on the marker and then the "Google Street View" link - it never fully opens the first time?

If you reload the page and click again it works....??

Steve

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Tue Jun 21, 2011 6:06 pm

Is it possible to have the balloon tip show when the map loads instead of having to click on the marker..
Sorry the map only uses a onclick event to dispaly the ballon.

Cant reall say it could just be a small lag in time for it to be brought into your page and when you refresh it gets called fater because it is already in your browsers cache.
The extension alread has this feature installed if you notice the small man icon in the map if the users drags this on top of the pin icon it will give a streetview..

smartmedia
 
 
Posts: 66
Joined: Wed Jan 26, 2011 7:51 pm
Location: Hellas

Re: Google Maps API v3 ***Update 07/06/11***

Post by smartmedia » Wed Aug 10, 2011 3:56 pm

Hi..

I spend 2 hours to figure out why the extension not working for me. I was getting the Lat & Lon from here
Well, in the extension the order is Lon & Lat instead of Lat & Lon, during copy i din't notice. Please correct it because i am sure some users will have the same result as me.
Question:
Why you create an extra page for the extension like googlemaps.html you can't just use the code inside a div...???
Notice:
In the field (Map Icon Image Title) i add a message in Greek but is shown as Chinese. Any idea why...??? Perhaps because u using the extra page googlemaps.html.

That's all for now. Thanks
infogate
<script type="text/javascript">jQuery.noConflict();</script>

User avatar
BaconFries
 
 
Posts: 4712
Joined: Thu Aug 16, 2007 7:32 pm

Re: Google Maps API v3 ***Update 07/06/11***

Post by BaconFries » Wed Aug 10, 2011 5:50 pm

I spend 2 hours to figure out why the extension not working for me. I was getting the Lat & Lon from here Well, in the extension the order is Lon & Lat instead of Lat & Lon,
If you maybe had spent either 5 minutes looking through previous posts you would have found the anwser or taking the time to post and I would have replied...
Why you create an extra page for the extension like googlemaps.html you can't just use the code inside a div...???
WHY so that you can use more than one map per site and because the javascript that it is using is HTML 5 complient if you try and mix on the same page the w3C gives errors that is why it is in a iframe....
In the field (Map Icon Image Title) i add a message in Greek but is shown as Chinese. Any idea why...??? Perhaps because u using the extra page googlemaps.html.
I dont know I dont speak greek!!!!! and I have no need to use cryliic characters .....I dont and cant test to make sure it works for every persons language that would take forever...did you try using with the unicode version of the builder?????

And finally if you dont like how the Map works or how I bulit it ...then there are more than just this one available to use...and YES that will be ALL for now

Post Reply