"Not active" in Login Admin file allowing access

Issues related to the Login tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/login_basics.html
http://www.wysiwygwebbuilder.com/login_tools.html

TIP:
A lot of information about the login tools can be found in the help/manual.
Also checkout the demo template that is include with the software.
trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Re: "Not active" in Login Admin file allowing access

Post by trenoweth » Tue Jun 05, 2018 7:31 am

So if I rearrange it so that the active field is number five, that should resolve things?

I do still have active as 5, though starting with 0 that probably means it is really 6

This is my amended coding:

$values = explode('|', trim($line));

$values[0] = $_POST['login'];

if (!empty($_POST['password']))

{

$values[1] = md5($_POST['password']);

}

$values[2] = $_POST['email'];

$values[3] = $_POST['firstname'];

$values[4] = $_POST['surname'];

$values[5] = $_POST['active'];

With corresponding amendment elsewhere.

Would simply moving the active field work so that, for example, I have (1) User name,(2) First name, (3) Surname, (4) Email, (5) Active with the hidden password field for the sixth one?

You have asked which version I have, but where is that shown? As I have said I downloaded it on 4th June, but these files were already in existence then. When I look at the About tab it just has Version 14 (May 7 2018), as here.
Image

Anyway, these files were produced in an earlier version.

User avatar
Pablo
 
Posts: 13498
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: "Not active" in Login Admin file allowing access

Post by Pablo » Tue Jun 05, 2018 7:36 am

So if I rearrange it so that the active field is number five, that should resolve things?
Correct
Would simply moving the active field work so that, for example, I have (1) User name,(2) First name, (3) Surname, (4) Email, (5) Active with the hidden password field for the sixth one?
All standard fields need to be in their original position, extra fields should be added at the end of the line.
When I look at the About tab it just has Version 14 (May 7 2018), as here.
This is not the most recent version. Please install the latest update.
https://www.wysiwygwebbuilder.com/forum ... um.php?f=1

trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Re: "Not active" in Login Admin file allowing access

Post by trenoweth » Tue Jun 05, 2018 7:39 am

This is not the most recent version
Well, it is what I downloaded this very week!

trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Re: "Not active" in Login Admin file allowing access

Post by trenoweth » Tue Jun 05, 2018 7:43 am

Is this 14.0.4 an update or a new paid-for program? It's only just over two months since I last paid you for an upgrade!

User avatar
Pablo
 
Posts: 13498
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: "Not active" in Login Admin file allowing access

Post by Pablo » Tue Jun 05, 2018 8:57 am

If you have a license for version 14.x then all updates for this version are free.

trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Re: "Not active" in Login Admin file allowing access

Post by trenoweth » Tue Jun 05, 2018 9:14 am

I have, thank goodness!

trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Edit problem in Login Admin file

Post by trenoweth » Wed Jun 06, 2018 2:10 am

Now I have another problem! Using v14.0.4 and writing completely new files without any additional field added the program works alright as far as signing-up and using the admin page are concerned, also the active/not active function. But when I click on edit I can see that a new sign-up is denoted as an Administrator. Changing that to 'Member' or 'Guest' and saving doesn't, in fact, have any effect as when checking the edit box again it is still showing 'Administrator'.

User avatar
Pablo
 
Posts: 13498
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: "Not active" in Login Admin file allowing access

Post by Pablo » Wed Jun 06, 2018 6:01 am

User roles and avatars in WWB14 only work with MySQL database. This functionality was not designed to be used with flat database.

trenoweth
 
 
Posts: 63
Joined: Mon Feb 08, 2016 10:42 pm
Location: Punganui, New Zealand

Re: "Not active" in Login Admin file allowing access

Post by trenoweth » Wed Jun 06, 2018 6:08 am

Ah, right, well ... I don't really require the roles so that's not a problem for me. Thanks.

Better have a look at MySQL when I have a moment though.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest