EB4 blank and space

This section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Forum rules
This forum section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Post Reply
jordan
 
 
Posts: 846
Joined: Tue Jun 26, 2007 1:56 pm
Contact:

EB4 blank and space

Post by jordan » Wed Jun 06, 2012 3:13 pm

hello support, very nice new version EB4 TNX!

but could you please revert to xsl parse blank instead to space
cause using a blank input does not work anymore
which means any input that is blank will return an error/fail
if you have an input like …

next = '#NextButton' ---> works
next = '' ------------------> works
next = ' ' -----------------> won't work

so you can never create an input with an empty value ?
this causes many of my extensions to not work anymore !

other then that EB4 seems to work out of the box . 8) , but please revert … :| .

User avatar
Pablo
 
Posts: 20153
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: EB4 blank and space

Post by Pablo » Wed Jun 06, 2012 3:38 pm

Can you please be more specific? To which part of EB is this related?
How can I reproduce this behavior?

jordan
 
 
Posts: 846
Joined: Tue Jun 26, 2007 1:56 pm
Contact:

Re: EB4 blank and space

Post by jordan » Wed Jun 06, 2012 4:18 pm

a dataset example

==========================================================================================
EB xsl edit
$('<xsl:value-of select="ID"/>').css('background-color','<xsl:value-of select="COLOR"/>');

WB property edit could be
'#Layer1' : '#000000' ––> before 8.2.0 – here the value is set – works
'' : '#000000' ––––––--–––> before 8.2.0 – here the value is empty (blank) – still works

' ' : '#000000' ––––––––-> after 8.2.0 – WB 8.2.0 creates a (space) when a value is empty – this does not work

==========================================================================================

if a value is empty then WB 8.2.0 creates a (space) as value instead of a (blank) value, this causes errors/fails
so, instead of '-nothing-' WB 8.2.0 creates a '-space-' between the quotes

User avatar
Pablo
 
Posts: 20153
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: EB4 blank and space

Post by Pablo » Wed Jun 06, 2012 7:37 pm

Ok, thanks I will check it out tomorrow (I cannot remember changing anything to this behavior, but I'm sure you are right).
Is it possible that this is a 'tab' instead of a space?

jordan
 
 
Posts: 846
Joined: Tue Jun 26, 2007 1:56 pm
Contact:

Re: EB4 blank and space

Post by jordan » Wed Jun 06, 2012 9:08 pm

Ok thank you, no tab I think it's a space ?

User avatar
Pablo
 
Posts: 20153
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: EB4 blank and space

Post by Pablo » Thu Jun 07, 2012 10:17 am

The preview of WWB 8.2 has been updated to fix the spacing problem.

jordan
 
 
Posts: 846
Joined: Tue Jun 26, 2007 1:56 pm
Contact:

Re: EB4 blank and space

Post by jordan » Thu Jun 07, 2012 11:59 am

Works like a charm now, thank you much!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest