HTML link issue

This section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Forum rules
This forum section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Post Reply
User avatar
me.prosenjeet
 
 
Posts: 1463
Joined: Mon Dec 24, 2007 1:50 pm
Location: Lucknow
Contact:

HTML link issue

Post by me.prosenjeet » Tue Jan 26, 2016 4:37 pm

I am working on a script extension, the structure is as under:
index.html
-----base_folder
-----------css
---------------style.css
Now in 'base_folder' I need to upload a logo which is mentioned in style.css as '../logo.pmg'(in extension written as $logo$)

In the extension builder when I choose "base_folder" as the upload folder, and I publish, the link that is replaced for $logo$ is './base_folder/logo.png'

and when I preview the index.html, the logo doesn't show.

I want it to set in a way that the logo uploaded by the user uploads inside "base_folder" and a correct link replaces $logo$ in the style.css file so that the logo displays correctly in the index,html
Any help welcome please

User avatar
Pablo
 
Posts: 19288
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HTML link issue

Post by Pablo » Tue Jan 26, 2016 6:26 pm

I'm sorry I'm currently too busy to help you with building extensions.

User avatar
me.prosenjeet
 
 
Posts: 1463
Joined: Mon Dec 24, 2007 1:50 pm
Location: Lucknow
Contact:

Re: HTML link issue

Post by me.prosenjeet » Tue Jan 26, 2016 10:29 pm

I can understand Pablo, with the launch of wb11

Others, Im sure some of you are masters in ext development- bacon, rz, naval, jordan- to name a few

User avatar
[RZ]
 
 
Posts: 2430
Joined: Tue Nov 04, 2008 12:08 pm

Re: HTML link issue

Post by [RZ] » Tue Jan 26, 2016 11:14 pm

extb / properties / edit property ->
type: file
publish to folder: base_folder/css

extb / files ->
new folder: base_folder
(click on base_folder to remain it selected)
new folder: css
(click on css to remain it selected)
add files: logo.png

the ext should point then to base_folder/css/$logo$

User avatar
me.prosenjeet
 
 
Posts: 1463
Joined: Mon Dec 24, 2007 1:50 pm
Location: Lucknow
Contact:

Re: HTML link issue

Post by me.prosenjeet » Wed Jan 27, 2016 10:04 am

Thanks RZ, will implement and let you know :D

User avatar
me.prosenjeet
 
 
Posts: 1463
Joined: Mon Dec 24, 2007 1:50 pm
Location: Lucknow
Contact:

Re: HTML link issue

Post by me.prosenjeet » Wed Jan 27, 2016 6:19 pm

Rz

I could sort it, not your way but its working now. Thanks for the help

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest