Issue with Extension Builder 6

This section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Forum rules
This forum section can be used to submit suggestions for Extension Builder.
Note that this section is not monitored for support.
Post Reply
presto
 
 
Posts: 226
Joined: Tue Aug 24, 2010 5:19 pm

Issue with Extension Builder 6

Post by presto » Thu May 10, 2018 11:32 am

HTML code of extension does not publish content inserted in the 'After <body>tag' area or in the 'Before </body> tag' area of extension builder 6.

User avatar
Pablo
 
Posts: 14518
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Issue with Extension Builder 6

Post by Pablo » Thu May 10, 2018 1:34 pm

Maybe you have enabled one of the HTML/JavaScript formatting options in Tools->Options->HTML?

presto
 
 
Posts: 226
Joined: Tue Aug 24, 2010 5:19 pm

Re: Issue with Extension Builder 6

Post by presto » Thu May 10, 2018 5:32 pm

I mean in the HTML Code of the preview in extension builder itself. And no, I haven't enabled any formatting options in WWB 14.

I wonder if WWB directly is influencing the extension builder while generating and testing an extension within extension builder. Does it?

User avatar
Pablo
 
Posts: 14518
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Issue with Extension Builder 6

Post by Pablo » Thu May 10, 2018 6:01 pm

Sorry, Extension Builder itself does not support these options.
In older versions all functionality was implemented in the extension itself, but later this has been moved to WWB for performance and maintenance reasons (the extension does not need to be updated when a bug is fixed in the functionality).
This means that newer functionality is not available in the 'simulator'.

presto
 
 
Posts: 226
Joined: Tue Aug 24, 2010 5:19 pm

Re: Issue with Extension Builder 6

Post by presto » Thu May 10, 2018 6:19 pm

Thanks for clarification. So if I put some content there, it will not be supported by the build in 'simulator' but it will be in the extension, nevertheless?

If this is not the case, doesn't it mean that the tabs "After <body> tag" and "Before </body> tag" in Extension Builder 6 are obsolet? Then they should be deleted to avoid confusion.

User avatar
Pablo
 
Posts: 14518
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Issue with Extension Builder 6

Post by Pablo » Thu May 10, 2018 6:27 pm

but it will be in the extension, nevertheless?
Correct
If this is not the case, doesn't it mean that the tabs "After <body> tag" and "Before </body> tag" in Extension Builder 6 are obsolet?
These options are not obsolete, but they only work in the application, not in Extension Builder preview.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest