HTLM Audio Player

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
andyp
 
 
Posts: 417
Joined: Fri Aug 08, 2014 8:56 am
Location: Brighton UK
Contact:

HTLM Audio Player

Post by andyp » Tue Apr 24, 2018 1:22 pm

WB 12.5.1

I am unable to get the Html Audio Player to work when entering the path to where the file is located

This is similar to the Plyr extension which works fine with the same path to the files (although this does not allow titles like the HTML Audio Player does)

Audio Test page at www.bhtaxinews.cab/audio-test.html

Thanks

AndyP
Making mistakes....and still learning as I go along.. and very grateful to those who know far more than me... :)
http://www.apgraphx.co.uk

User avatar
BaconFries
 
 
Posts: 4239
Joined: Thu Aug 16, 2007 7:32 pm

Re: HTLM Audio Player

Post by BaconFries » Tue Apr 24, 2018 1:44 pm

You have used invalid naming, file names should not start with numbers or have and invalid characters within them.
How do I name my pages, images and other files?

pajadt
 
 
Posts: 502
Joined: Sat Mar 16, 2013 11:23 am
Location: Europe
Contact:

Re: HTLM Audio Player

Post by pajadt » Tue Apr 24, 2018 1:52 pm

Hi Andy
Your extension not work bacause you give wrong put mp3 files, change that and at work
NOW WRONG IS
audio/http://www.bhtaxinews.cab/audio/2018-ub ... art1-c.mp3

CORRECT IS
http://www.bhtaxinews.cab/audio/2018-ub ... art1-c.mp3
Change that and extension work

andyp
 
 
Posts: 417
Joined: Fri Aug 08, 2014 8:56 am
Location: Brighton UK
Contact:

Re: HTLM Audio Player

Post by andyp » Tue Apr 24, 2018 6:08 pm

Thanks to you both for the replies...

However I remain confused?

The path assigned to both players was:

http://www.bhtaxinews.cab/audio/2018-ub ... art1-c.mp3

However.. taking into consideration not having files beginning with a number I have changed the file name to:

http://www.bhtaxinews.cab/audio/a2018-u ... art1-c.mp3

and have used that in both players.. but still the HTML5 Audio Player does not work?

www.bhtaxinews.cab/audio-test.html
Thanks
Making mistakes....and still learning as I go along.. and very grateful to those who know far more than me... :)
http://www.apgraphx.co.uk

User avatar
Pablo
 
Posts: 17581
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HTLM Audio Player

Post by Pablo » Tue Apr 24, 2018 6:16 pm

First note that the HTML5 audio player is standard browser functionality, the player is implement by the browser so whether or not the audio plays has nothing to do with WWB.

By looking at the code it looks like the file name is still invalid. And it seems to be set to video instead of audio???

Code: Select all

<video poster="" controls>
<source src="http://www.bhtaxinews.cab/audio/2018-uber-renewal-Part1-c.mp3" type="audio/mp3" />
</video>
Also note that the Plyr extension does not support absolute paths. So, you will need to select a local file instead of an absolute URL.

User avatar
nerdtech
 
 
Posts: 21
Joined: Fri Jan 26, 2018 4:04 pm

Re: HTLM Audio Player

Post by nerdtech » Tue Apr 24, 2018 6:18 pm

The second player works for me. But the first player the link is wrong, you have put:

audio/http://www.bhtaxinews.cab/audio/a2018-u ... art1-c.mp3

Image

Take the audio/ off the URL.

When it should be:

Code: Select all

http://www.bhtaxinews.cab/audio/a2018-uber-renewal-Part1-c.mp3
Last edited by nerdtech on Tue Apr 24, 2018 6:25 pm, edited 1 time in total.

User avatar
BaconFries
 
 
Posts: 4239
Joined: Thu Aug 16, 2007 7:32 pm

Re: HTLM Audio Player

Post by BaconFries » Tue Apr 24, 2018 6:20 pm

In the Media Player please check the output settings instead of HTML5 Audio you may have selected HTML5 Video.

andyp
 
 
Posts: 417
Joined: Fri Aug 08, 2014 8:56 am
Location: Brighton UK
Contact:

Re: HTLM Audio Player

Post by andyp » Tue Apr 24, 2018 6:29 pm

Thanks for the reply but this is getting very confusing ;)

For the plyr extension this is showing as

var playlist = [{ "title" : "Part 1 A", "length" : "30:00", "filename" : "audio/http://www.bhtaxinews.cab/audio/a2018-u ... art1-c.mp3"},

For the HTML5 Audio Player this is showing as:

<source src="http://www.bhtaxinews.cab/audio/a2018-u ... art1-c.mp3" type="audio/mp3" />

.... which is the one that isnt working
Making mistakes....and still learning as I go along.. and very grateful to those who know far more than me... :)
http://www.apgraphx.co.uk

User avatar
BaconFries
 
 
Posts: 4239
Joined: Thu Aug 16, 2007 7:32 pm

Re: HTLM Audio Player

Post by BaconFries » Tue Apr 24, 2018 6:34 pm

For the HTML5 Audio Player this is showing as:
The source shows that you have used the HTML5 Video Object or your have set the HTML5 Audio to use HTML5 Video!

Code: Select all

<video poster="" controls>
<source src="http://www.bhtaxinews.cab/audio/a2018-uber-renewal-Part1-c.mp3" type="audio/mp3" />
</video>

andyp
 
 
Posts: 417
Joined: Fri Aug 08, 2014 8:56 am
Location: Brighton UK
Contact:

Re: HTLM Audio Player

Post by andyp » Tue Apr 24, 2018 6:43 pm

Thanks for the input baconfries....

Please see the screen shot that shows I am definately using HTML5 Audio Player and not the video player

Where would the setting be to change to video?

Thanks

Image
Making mistakes....and still learning as I go along.. and very grateful to those who know far more than me... :)
http://www.apgraphx.co.uk

User avatar
Pablo
 
Posts: 17581
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HTLM Audio Player

Post by Pablo » Tue Apr 24, 2018 8:23 pm

Please see my previous comments:
Also note that the Plyr extension does not support absolute paths. So, you will need to select a local file instead of an absolute URL.

andyp
 
 
Posts: 417
Joined: Fri Aug 08, 2014 8:56 am
Location: Brighton UK
Contact:

Re: HTLM Audio Player

Post by andyp » Tue Apr 24, 2018 8:32 pm

Pablo......The plyr extension works fine with the path that I have given it where it is stored on the server. yes it was set to video.. but does not make any difference if set to video because this one works fine.... I have changed it to audio which just give it a different layout.... it is a real shame that this one does not allow titles which is what I want to do

But thanks for the input... but I am probably be giving up on the HTML 5 Playlist now.... and will have to look for some other extension....
Making mistakes....and still learning as I go along.. and very grateful to those who know far more than me... :)
http://www.apgraphx.co.uk

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests