WYSIWYG 14 publish.dat file problems

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
User avatar
ely
 
 
Posts: 13
Joined: Sun Feb 25, 2007 3:17 pm
Location: Columbus, Ohio, USA
Contact:

WYSIWYG 14 publish.dat file problems

Post by ely » Sun Oct 07, 2018 10:14 pm

Just tried to publish, and only My Computer destination was available in the publish dialog pull-down.

Added my old FTP destination, and successfully published.

Same project, few minutes later, tried to publish another page. Newly added FTP location gone. Had to add again. Looked and gone again, never saved.

Looked in system folder & opened publish.dat with Notepad. All info was there and looked OK. Changed name of publish.dat to publish-old.dat.

Created new FTP destination in publish dialog & published a page. All went well. Looked in publish dialog, FTP destination not saved. Gone again. Looked in system folder and a newly created publish.dat was there. Opened with Notepad & new FTP destination is in the XML file.

How can I get WYSIWYG to save and use my new FTP destinations?

I'm using the default system folder setting, C:\Users\<user>\WYSIWYG Web Builder

Thanks

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WYSIWYG 14 publish.dat file problems

Post by Pablo » Mon Oct 08, 2018 5:55 am

Maybe you have changed the system folder in Tools->Options->Files & Folders?
In that case WWB will look in that folder for the publish.dat file. Maybe the folder is read-only?
Or maybe your firewall blocks the folder?

User avatar
ely
 
 
Posts: 13
Joined: Sun Feb 25, 2007 3:17 pm
Location: Columbus, Ohio, USA
Contact:

Re: WYSIWYG 14 publish.dat file problems

Post by ely » Mon Oct 08, 2018 1:17 pm

Maybe you have changed the system folder in Tools->Options->Files & Folders?
No. I'm using default options for that. The folder is as I posted in my original question, where <user> stands for my user name.
Maybe the folder is read-only?
No. I checked that file property before asking the question. Besides, when I renamed the original publish.dat, WWB14 reated a new one and still couldn't read it.
Or maybe your firewall blocks the folder?
I don't think so. I don't see how the firewall would get involved in a file that's in My Documents folder for a local user and that user's local process. Besides, when I renamed the original publish.dat to publish-old.dat, WWB14 re-created the publish.dat file. This is not a problem that I can't publish. The problem is that my FTP parameters are not read from the publish.dat file. They seem to be written to the file, but WWB14 doesn't populate the publish pull-down options with the data in the file.

One more piece of info. I also have WWB 12 & WWB 11 installed on my computer to maintain older sites I don't want to convert and upload in their entirety. WWB12 & WWB14 can't read the info in publish.dat. WWB 11 reads it fine.

Thanks

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WYSIWYG 14 publish.dat file problems

Post by Pablo » Mon Oct 08, 2018 1:24 pm

Besides, when I renamed the original publish.dat to publish-old.dat, WWB14 re-created the publish.dat file.
This confirms that something is wrong with the file permissions.
For example, maybe WB11/WB12 uses different user credentials as WB14?
I don't see how the firewall would get involved
Because the firewall manages access rights to files/folders. For the firewall WB12 and WB14 is a different application so it assigns different rights (based on your input)

User avatar
ely
 
 
Posts: 13
Joined: Sun Feb 25, 2007 3:17 pm
Location: Columbus, Ohio, USA
Contact:

Re: WYSIWYG 14 publish.dat file problems

Post by ely » Mon Oct 08, 2018 4:41 pm

I use the Windows Defender firewall. It only manages connections to the network. The security system manages access permissions.

Just to verify, I turned off the firewall and same thing.

OK, this is really strange...

I rebooted the computer and renamed the file publish-old.dat to publish.dat and WWB14 accessed my publish pull-down destination list just fine. I started WWB11 and WWB14 can no longer access the publish file... even after I closed WWB11.

It looks like a file locking problem. With ProcessExplorer, I found a process, RoxWatchTray9.exe that seems to have the file locked. This is a part of the Roxio software package. I used ProcessExplorer (running as Administrator) to close the handle for the file publish.dat. There were two handles for this file. I ran WWB14 and the destination list worked fine again without rebooting.

I don't know what's going on there, but it sure is strange. I think some other people were asking about similar problems. Wonder if they had file locking issues too.

User avatar
Pablo
 
Posts: 14199
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: WYSIWYG 14 publish.dat file problems

Post by Pablo » Mon Oct 08, 2018 4:54 pm

Note that WWB cannot prevent files from being locked by other tools.
You will need to contact the developers of RoxWatchTray9 about this.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests