Failed to open document

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 9:07 am


User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 10:45 am

I'm sorry, but something is wrong with the data in the project.
The name of the extension does not match with the data structure. It looks like another extension was renamed (manually) and the data was stored with the wrong name.
The only way to correct this is to restore the original extension from a backup.

Or maybe you can point me to the published page so I can maybe see which extension was used.

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 11:05 am


User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 11:13 am

ACB_2013_04_03_2014.wbs works for me.

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 11:19 am

I really appreciate your effort. I got an idea. In the beginning two errors were reported: (see images). These are two extensions that are not useful for the site, perhaps they were used only in some test page that has remained in the site structure. I reinstalled the extension massivemenu because I was still in possession. I have not installed the other extension because I do not have it. Looking at the error messages you can see that both extensions carry the name Extension1. Could this be the reason for the conflict?

Image

Image

User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 12:04 pm

The problem is not related to the ID of the extension (extesion1).
The software will not leave any references to the extension if you completely remove it from all pages.

User avatar
BaconFries
 
 
Posts: 4714
Joined: Thu Aug 16, 2007 7:32 pm

Re: Failed to open document

Post by BaconFries » Mon Oct 29, 2018 12:07 pm

I may have a copy of the breadcrumb extension on a flash drive for you to install so that you can open your project. I don't not have the drive at hand but will look for it later today.

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 12:40 pm

Thank you for your help. Previously, when there was a problem like this, wwb limited itself to reporting the problem. Now, unfortunately, the problem becomes blocking. I updated this site in July 2018 with the wwb11 version and I had no problems.

User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 2:28 pm

The error is not blocking if you press 'yes'. In that case it will work like it did before.
However, if you ignore the error then you may end up with a corrupt project. Because without the extension, the software does not know the data structure of the extension.

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 2:53 pm

here the problem will be more serious, because even if I click Yes, the message Failed to open appears

User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 2:57 pm

Yes, that is because of a previous error.
ACB_2013_04_03_2014.wbs works for me, so that backup is still correct. After that something has gone wrong. The name of the extension does not match the data structure, which usually indicates that an extension was renamed manually.
This can only be fixed (by you) by restoring a backup with that missing extensions.

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Mon Oct 29, 2018 3:09 pm

do you think that if BaconFries can find the extension, as he said, I could solve the problem?

User avatar
Pablo
 
Posts: 18751
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Failed to open document

Post by Pablo » Mon Oct 29, 2018 3:19 pm

I am not sure about that. Like I mentioned, the structure of the extension does not seem to match name of the extension. That is why the software does not know what to do with the data (which results in failed to load document).

Don't you have a backup with all your files so you can restore all extensions you had installed when it still worked?

User avatar
giula
 
 
Posts: 48
Joined: Sat Nov 14, 2009 11:19 pm

Re: Failed to open document

Post by giula » Wed Oct 31, 2018 6:57 pm

I resolved using a backup of 2016 but I had to upload all the subsequent updates. What happened is a mystery but some things are safe:
- The project was realized with the 11.50 version
- In July I updated and saved the site and I had no problem with version 11 of WWB
- No backups after 2016 can be uploaded by WWB (11-12-14)
- Even if there was an error in the last processing of July 2018 I should have been able to load the previous versions but it is not.
- I've never renamed any extension, just dummy.wbx

Thank you anyway for assisting me in the best possible way

Post Reply