seperate website for phone

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
ddaugherty
 
 
Posts: 32
Joined: Thu Sep 05, 2013 4:58 pm
Location: McKinney, TX
Contact:

seperate website for phone

Post by ddaugherty » Tue Nov 12, 2019 11:52 pm

This project has two different websites for the same domain name. One is 970px wide for large screens and the other is 370 wide for cell phones. There is a routine on the large site to redirect to the small site if the viewing screen is less than 400px.
The redirecting works fine but when viewing the smaller version on my phone, it seems to display like it is viewing on a large sceen. The data is in the middle with large white space on the left and right. What do I need to do to get it the 370px version to fill the sceen on a phone? Here is the link: http://vcs9.com/delights/
Note: the small version is in a subfolder. The folder is m.

User avatar
rogerl
 
 
Posts: 246
Joined: Tue May 03, 2016 8:24 am

Re: seperate website for phone

Post by rogerl » Wed Nov 13, 2019 1:07 am

Seems to be okay while viewing on my Samsung. Only white space I saw was briefly across the screen which looked more like a large image loading, probably the cake. Other than that works fine. Tried on Firefox mobile and Chrome mobile.

ddaugherty
 
 
Posts: 32
Joined: Thu Sep 05, 2013 4:58 pm
Location: McKinney, TX
Contact:

Re: seperate website for phone

Post by ddaugherty » Wed Nov 13, 2019 4:02 am

Thanks for checking. Maybe my phone is having a problem. I'll check on another phone.

ddaugherty
 
 
Posts: 32
Joined: Thu Sep 05, 2013 4:58 pm
Location: McKinney, TX
Contact:

Re: seperate website for phone

Post by ddaugherty » Wed Nov 13, 2019 5:07 pm

I checked the website on another phone and still having the same problem. Here is a screenshot from my phonehttp://vcs9.com/delights/mobile_website.png. The width of the site is only 370px, but it's showing like it is a 970px layout. How can I get this mobile site to display properly on a cell phone? Thanks

User avatar
Pablo
 
Posts: 18647
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: seperate website for phone

Post by Pablo » Wed Nov 13, 2019 5:12 pm

I do not see anything wrong. If there are no breakpoints then the browser will treat the page as desktop page.
Why did you create a separate page for mobile, instead of using breakpoints?

User avatar
crispy68
 
 
Posts: 628
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: seperate website for phone

Post by crispy68 » Wed Nov 13, 2019 10:56 pm

I viewed it on my Galaxy 7 and saw the same issue you are having.

Your problem is your 'mobile' page is missing a 'viewport' tag. I would also suggest that you make your minimum width 360px versus 370px. Many phones have a viewport of 360px and yours may cause a small horizontal scroll bar at the bottom.

You need to add this:

Code: Select all

<meta name="viewport" content="width=device-width, initial-scale=1.0">
This can be done with WB by clicking on the page properties --> meta tags and checking the box to add the viewport tag.

I would also agree with Pablo. The use of a redirect to a mobile page is rarely done anymore. The use of breakpoints or creating a floating layout is much better and easier to maintain. I would highly recommend converting the site.

Post Reply