1920 BP Not Centering?

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
Post Reply
User avatar
ColinM
 
 
Posts: 469
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

1920 BP Not Centering?

Post by ColinM » Sat Nov 12, 2016 10:27 pm

Hi Pablo

In one of my projects I am having a strange behaviour on the 1920 BP - it is not centering unless I place an object hard right against the 1920 view port boundary.

The project uses a Master Frame.

Centering of content works fine in all other BPs.

The Master Frame is centered as is the respective test demonstration pages:

TEST - HERE is the 1920 page with an object hard right in the 1920 view port - the content is centered.

TEST2 - Now HERE is the same page with the hard right object removed - the content shifts right?
Yours truly
Colin M
Western Australia
My Website

filmphotog
 
 
Posts: 115
Joined: Sat Sep 05, 2015 7:20 am
Location: Sweden
Contact:

Re: 1920 BP Not Centering?

Post by filmphotog » Sun Nov 13, 2016 7:52 am

Hi, I think TEST2 shifts to the right because the Content Place Holder ->Properties->General->Alignment is set to Center. Does setting alignment to Left change this?

User avatar
ColinM
 
 
Posts: 469
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: 1920 BP Not Centering?

Post by ColinM » Sun Nov 13, 2016 8:30 am

Hi - filmphotog - Thanks for trying, but I don't believe that's the issue - all the other break points are set centered and work fine. Let's wait and see what Pablo says ay. 8)

Although, just having done some testing, setting the 1920 (default) CPH to left DOES result in the content in Test 2 being centered - weird.
Yours truly
Colin M
Western Australia
My Website

User avatar
Pablo
 
Posts: 17961
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: 1920 BP Not Centering?

Post by Pablo » Sun Nov 13, 2016 8:48 am

I'm sorry I do not know why the browser centers it differently.
It may be related to the full width header/footer which affects the internal 'auto margin' calculations of the browser.

User avatar
ColinM
 
 
Posts: 469
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: 1920 BP Not Centering?

Post by ColinM » Sun Nov 13, 2016 9:28 am

Pablo wrote:I'm sorry I do not know why the browser centers it differently.
It may be related to the full width header/footer which affects the internal 'auto margin' calculations of the browser.
Thanks Pablo - very strange - I thought it was another case of missing something obvious, but, unfortunately, that doesn't seem to be the case.
Yours truly
Colin M
Western Australia
My Website

User avatar
ColinM
 
 
Posts: 469
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: 1920 BP Not Centering?

Post by ColinM » Mon Nov 14, 2016 2:52 am

filmphotog wrote:Hi, I think TEST2 shifts to the right because the Content Place Holder ->Properties->General->Alignment is set to Center. Does setting alignment to Left change this?
As a follow on for this issue, I tried replicating the master frame with a page header and footer, painstakingly preview testing as I went - with everything centered - all was working fine until I got to the 320 break point and the "right shove" - re-occurred - what was even more weird was I cancelled out of the project (to revert back to pre 320 BP) and it still shoved right.

The only way I can get it to centre is have the Content Place Holder set to left alignment.

filmphotog - how did you know setting the content place holder alignment to left would/might work?
Yours truly
Colin M
Western Australia
My Website

filmphotog
 
 
Posts: 115
Joined: Sat Sep 05, 2015 7:20 am
Location: Sweden
Contact:

Re: 1920 BP Not Centering?

Post by filmphotog » Mon Nov 14, 2016 6:31 am

:D I always have the content place holder alignment set to left, I did this after testing what works best. The width of the CPH is fixed and if the content has smaller width I want it to align left (this is pre-layoutgrids, floating text thinking though). I guessed your TEST2 could be similar.

User avatar
ColinM
 
 
Posts: 469
Joined: Wed Feb 09, 2011 3:40 am
Location: Western Australia
Contact:

Re: 1920 BP Not Centering?

Post by ColinM » Mon Nov 14, 2016 6:49 am

filmphotog wrote::D I always have the content place holder alignment set to left, I did this after testing what works best. The width of the CPH is fixed and if the content has smaller width I want it to align left (this is pre-layoutgrids, floating text thinking though). I guessed your TEST2 could be similar.
OK - thanks filmphotog - I guess that makes sense - I think. One would think that if everything is horizontally centered, including the CPH, then all objects should be centered. There are the occasional times when website design does one's head in :lol:
Yours truly
Colin M
Western Australia
My Website

Post Reply