Panel Layer and font awsome Icons don't change color

Questions related to the Responsive Web Design tools of WYSIWYG Web Builder.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/respon ... esign.html
Please read this first before posting any questions! Also check out the example project to get an idea how the RWD concept works.

Responsive Web Design FAQ:
http://wysiwygwebbuilder.com/forum/view ... 10&t=63817
Post Reply
linkternet
 
 
Posts: 12
Joined: Tue Feb 02, 2016 7:43 pm

Panel Layer and font awsome Icons don't change color

Post by linkternet » Sun Nov 20, 2016 10:01 am

Hi,
I have a page with a simple text and break points resolutions 980,768,450 and 320. This page includes a master frame page with a header and a footer for all four resolutions and a panel layer that should be shown by clicking in a hamburger icon, included only in 450px and 320px resolutions.

I'm having some problems

1. The Panel layer, at design time has a background color assigned and when the page is generated, the color displayed is different.

2. The Hamburger icon, which is a font awsome icon, at design time in resolution 320px is displayed beyond the 320 area and there's no way to click on it to place it inside the working area. Double clicking it in the object manager does not select it and when I select it from the properties panel, it's properties are not shown so I can't modify it's position.

3. I tried duplicating the hamburger icon so 450px and 320px have different instances, the problem that arised was the same that I have with the panel layer. One color assigned in the properties and a different color once generated.

I updated to version 11.2.4, cleared browser cache and tried different options without luck.

Any advise will be very appreciated.

http://linkternet.com/wysiwyg/proyectfile.htm

User avatar
Pablo
 
Posts: 17995
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Panel Layer and font awsome Icons don't change color

Post by Pablo » Sun Nov 20, 2016 12:17 pm

1. The panel menu uses the color set in the default view. You have set a different color in breakpoints.
- Unhide the panel menu in the default view
- set the desired color
- hide the panel menu again

2. Go to the 32o breakpoints and then in the Object Manager right click the Hamburger Icon and select 'Reset position'

3. The color must be set the default view otherwise it will have a random or undefined color.

linkternet
 
 
Posts: 12
Joined: Tue Feb 02, 2016 7:43 pm

Re: Panel Layer and font awsome Icons don't change color

Post by linkternet » Tue Nov 22, 2016 6:53 pm

Thank you Pablo, I just made the suggested changes and everything works perfect.

It just seemed obvious to me to change the colors inside each breakpoint and expect the changes to apply.
So any changes like this should be done in the Default view always?
This means that it's no possible to have the same panel layer on two or more breakpoints and use different colors on each one?

Thank you.

User avatar
Pablo
 
Posts: 17995
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Panel Layer and font awsome Icons don't change color

Post by Pablo » Tue Nov 22, 2016 7:28 pm

So any changes like this should be done in the Default view always?
That depends on whether the object supports responsive colors.
The Panel menu is a very complicated object so it does not support responsive colors.

Post Reply