Upgrading to dedicated SSL through web-host thrown off WB site?

This section is for posting questions which are not directly related to WYSIWYG Web Builder.
Examples of off topics: web server configuration, hosting, programming related questions, third party scripts.

Note that these questions will generally not be answered by the administrators of this forum.
Post Reply
User avatar
etcbbu
 
 
Posts: 429
Joined: Mon Apr 23, 2007 3:00 pm

Upgrading to dedicated SSL through web-host thrown off WB site?

Post by etcbbu » Fri Mar 30, 2018 6:25 pm

Looking at purchasing a dedicated SSL and activating it for my website through my web-host, but want to know what all I should think about and check and have in mind with my project in WB, in doing this, to make sure the site I do with WB continues running correctly and isn't broken or anything..?
www.ktravisj.com

Travis J Consulting, LLC -
Website Design/Development/Maintenance, Web-Marketing/Social Media/Social Networking, SEO/Search Engine Optimization

www.ktravisj.com

User avatar
BaconFries
 
 
Posts: 4465
Joined: Thu Aug 16, 2007 7:32 pm

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by BaconFries » Fri Mar 30, 2018 6:33 pm

Will move to 'Off Topic Section' were other ssl questions have been asked.

antony
 
 
Posts: 47
Joined: Sun Aug 20, 2017 4:00 pm
Contact:

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by antony » Fri Mar 30, 2018 7:20 pm

Hello, to make sure that your site will work correctly with SSL, you should check that all the code of your site is securely transmitted. If you've inserted
third-party scripts, make sure that their origins also use SSL to avoid mixed-content. I would suggest you to try with a free SSL before buying to make sure that everything works fine. You can get free certificates from Let's Encrypt- https://www.sslforfree.com/
Regards,
Antony

User avatar
etcbbu
 
 
Posts: 429
Joined: Mon Apr 23, 2007 3:00 pm

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by etcbbu » Fri Mar 30, 2018 7:25 pm

So since our website is almost entirely just JPG/PNG imagegs, and text, the pages should all load ok? It's just, if there is a linkage to, say, and embedded video or embedded google object that does not have https:// , that will not show? Does that also mean any and all outbound links to websites that are not https:// will also not show, or, the link will not work?

Or is it that a page of my website will not even LOAD if there is anything like an outbound link to a non-https website, or an embedded thing that is not https?
www.ktravisj.com

Travis J Consulting, LLC -
Website Design/Development/Maintenance, Web-Marketing/Social Media/Social Networking, SEO/Search Engine Optimization

www.ktravisj.com

antony
 
 
Posts: 47
Joined: Sun Aug 20, 2017 4:00 pm
Contact:

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by antony » Fri Mar 30, 2018 7:33 pm

Your website will work fine. The links will work no matter if they are HTTP or HTTPS. Only if you've embed non-https scripts from third-party websites like videos for example, they will either not show or they will show on the page, but the browser will not display the Padlock icon. This is called mixed-content. Generally I think that you won't have any problems with SSL.

User avatar
etcbbu
 
 
Posts: 429
Joined: Mon Apr 23, 2007 3:00 pm

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by etcbbu » Fri Mar 30, 2018 7:34 pm

Thank you for the insights.

--etcbbu
www.ktravisj.com

Travis J Consulting, LLC -
Website Design/Development/Maintenance, Web-Marketing/Social Media/Social Networking, SEO/Search Engine Optimization

www.ktravisj.com

antony
 
 
Posts: 47
Joined: Sun Aug 20, 2017 4:00 pm
Contact:

Re: Upgrading to dedicated SSL through web-host thrown off WB site?

Post by antony » Fri Mar 30, 2018 7:34 pm

You're welcome.

Post Reply