HMTL snippet problem

This section is for posting questions which are not directly related to WYSIWYG Web Builder.
Examples of off topics: web server configuration, hosting, programming related questions, third party scripts.

Note that these questions will generally not be answered by the administrators of this forum.
Post Reply
User avatar
SteffJay
 
 
Posts: 32
Joined: Mon Dec 31, 2007 7:09 pm

HMTL snippet problem

Post by SteffJay » Sat Dec 15, 2018 5:03 pm

I have added an HTML snippet to my index page making some fireworks explode. However, the icons on the page hide the fireworks. I have tried to move the icons "move to back" to try and bring the firework HTML forward "move to front" but to no avail. :(

Is there a way of making the HTML snippet override all of the icons on the index page so that the fireworks can be seen?

Thanks in advance.

User avatar
Pablo
 
Posts: 17644
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HMTL snippet problem

Post by Pablo » Sat Dec 15, 2018 5:15 pm

"move to front" does not work with custom scripts because the software has no idea how your the code works so it cannot modify it.
You will need to modify the script so it has a higher z-index than all other elements on the page.

User avatar
SteffJay
 
 
Posts: 32
Joined: Mon Dec 31, 2007 7:09 pm

Re: HMTL snippet problem

Post by SteffJay » Sun Dec 16, 2018 11:27 am

Pablo wrote:
Sat Dec 15, 2018 5:15 pm
"move to front" does not work with custom scripts because the software has no idea how your the code works so it cannot modify it.
You will need to modify the script so it has a higher z-index than all other elements on the page.
Thanks for the reply.

Not being a "coder" i have no idea how to modify the script to make a higher z-index. Is it possible to make the HTML snippet a higher z-index? If so, how can this be achieved?

Thanks in advance.

User avatar
Pablo
 
Posts: 17644
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HMTL snippet problem

Post by Pablo » Sun Dec 16, 2018 2:07 pm

There is no generic answer to this question.
It completely depends on how the code works, so you will need to understand how the code works to be able to modify it.

User avatar
SteffJay
 
 
Posts: 32
Joined: Mon Dec 31, 2007 7:09 pm

Re: HMTL snippet problem *** SOLVED ***

Post by SteffJay » Tue Dec 18, 2018 12:23 pm

Pablo wrote:
Sun Dec 16, 2018 2:07 pm
There is no generic answer to this question.
It completely depends on how the code works, so you will need to understand how the code works to be able to modify it.
As you suggested the "z-index" needs to be changed in the HTML snippet, i could not find any reference to it at all in the script. So, what i had to do was go through the index page of my site and change every reference to the z-index from each progressive setting back to zero. This now works fine and the fireworks now show over all of the index gfx :D

User avatar
Pablo
 
Posts: 17644
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HMTL snippet problem

Post by Pablo » Tue Dec 18, 2018 12:46 pm

As you suggested the "z-index" needs to be changed in the HTML snippet,
Correct
i could not find any reference to it at all in the script.
Then you will need to add it yourself.

For example, if the firework is created using a div container, then add a z-index to that container.
I do not recommend to change the z-index of the WWB code , it may have 'random' side effects.

User avatar
SteffJay
 
 
Posts: 32
Joined: Mon Dec 31, 2007 7:09 pm

Re: HMTL snippet problem

Post by SteffJay » Tue Dec 18, 2018 1:36 pm

Pablo wrote:
Tue Dec 18, 2018 12:46 pm
As you suggested the "z-index" needs to be changed in the HTML snippet,
Correct
i could not find any reference to it at all in the script.
Then you will need to add it yourself.

For example, if the firework is created using a div container, then add a z-index to that container.
I do not recommend to change the z-index of the WWB code , it may have 'random' side effects.
Thank you for your assistance :D

User avatar
SteffJay
 
 
Posts: 32
Joined: Mon Dec 31, 2007 7:09 pm

Re: HMTL snippet problem

Post by SteffJay » Wed Dec 19, 2018 11:19 am

Unfortunately, there is no div container in the script.

User avatar
Pablo
 
Posts: 17644
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: HMTL snippet problem

Post by Pablo » Wed Dec 19, 2018 12:22 pm

Unfortunately, I cannot help you modifying the code. For me, this may also take a lot of time.
But this is not specific for WWB.

Post Reply