Intenet exception Error 12014

Issues related to previewing and publishing your web site.
Post Reply
Yves
 
 
Posts: 4
Joined: Mon Apr 26, 2021 9:02 am

Intenet exception Error 12014

Post by Yves » Mon Apr 26, 2021 5:50 pm

I have been using WWB since 2007 with a previous version (WWB3 I believe).
Since, I regularly upgraded the sofware and yesterday I upgraded it to WWB 16.3.0 and I cannot publish anymore.
This is the message I receive :

*** START OF PUBLISH ***
Scanning publish folder...
Found 5 file(s).
Initializing FTP connection...
Checking host...
Host was successfully parsed.
Connecting to ftp.tonquedec.net...
Using PASV mode.
Internet Exception Error 12014

Details:
Le mot de passe n'était pas autorisé
Closing FTP connection...
Removing temporary files...
Publish failed!
*** END OF PUBLISH ***

I checked with my webhost (Infomaniak in Switerland) and on his side, everythings are OK. I did not change anything.
What should I do ?
Thank you
Yves

User avatar
BaconFries
 
 
Posts: 4050
Joined: Thu Aug 16, 2007 7:32 pm

Re: Intenet exception Error 12014

Post by BaconFries » Mon Apr 26, 2021 6:01 pm

This is because your password could not be authorised!. Please ensure that you are entering this correctly eg.the spelling and try again. If it still fails then your host may have changed it and you should contact them.
Details:
Le mot de passe n'était pas autorisé
English translation
The password was not authorized

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Mon Apr 26, 2021 6:01 pm

I doubt that this has anythnig to do with the update. If there were any known issues in the software then they would have already been fixed.
The error indicates that the password is wrong.
Note that the entered password will be sent to the serve "AS IS".

Usually when something suddenly stops working there was something changed on the server side.
- make sure the password is still correct
- maybe your webhost requires you to use secure ftp?
- alternatively, you can set the FTP engine to 'winsock', if you get the same error then you can be sure it is server related.

Yves
 
 
Posts: 4
Joined: Mon Apr 26, 2021 9:02 am

Re: Intenet exception Error 12014

Post by Yves » Tue Apr 27, 2021 6:03 am

Thanks for your answer.
I agree that the problem has nothing to do with the update, as I tried to publish with my previous version (WWB 14) and the issue remains the same.
On the webhost side, for their part they assure me that everything is working perfectly as you can read in the last e-mail they sent me (translated from French to English for you) :

Infomaniak Network support

Apr 23, 08:00 AM (4 days ago)

To yves
Dear Monsieur de Tonquédec,

Thanks for your feedback.

Access to the FTP works correctly, proof in attachment, its access via the Web FTP is functional.

In addition, by searching quickly on the internet, it would appear that the problem encountered is a known problem:

viewtopic.php?f=20&t=85763&sid=10f56e38 ... 1&start=15

Initially, we thought the problem was with V1 hosting (which was experiencing instabilities when you called).

But after a restart of the infrastructure and numerous tests, it is now obvious that the problem lies with the software itself.


Following your recommendations, I also set the FTP engine to 'winsock' . And I checked the password is still correct. But issue remains the same .
Regards
Yves




____________________________________________________________________

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Tue Apr 27, 2021 6:20 am

The error indicates that the password is wrong. This error is a reply from the server.
Can you login with the same password with another FTP tool?
Did you try winsock? What is the error in that case?

Yves
 
 
Posts: 4
Joined: Mon Apr 26, 2021 9:02 am

Re: Intenet exception Error 12014

Post by Yves » Wed Apr 28, 2021 7:51 am

I checked the password : It is correct
I tried setting FTP engine to winsock and here is the reply :

*** START OF PUBLISH ***
Scanning publish folder...
Found 5 file(s).
SecureFtpLog:
Connect_Ftp2:
DllDate: Jan 31 2018
SecureFtpVersion: 9.5.0.72
UnlockPrefix: PBLVND.CB1072018
Architecture: Little Endian; 64-bit
Language: Visual C++ 2015 / x64
VerboseLogging: 0
ProgressMonitoring:
enabled: no
heartbeatMs: 0
sendBufferSize: 65536
--ProgressMonitoring
ImplicitSsl: 0
AuthTls: 0
AuthSsl: 0
ftpConnect:
Hostname: ftp.tonquedec.net
Port: 21
IdleTimeoutMs: 60000
socketOptions:
SO_SNDBUF: 262144
SO_RCVBUF: 4194304
TCP_NODELAY: 1
SO_KEEPALIVE: 1
--socketOptions
readCommandResponse:
replyLineQP: 220 pyftpdlib based ftpd ready.
--readCommandResponse
initialStatus: 220
initialResponse: 220 pyftpdlib based ftpd ready.
--ftpConnect
Logging in...
Login:
sendCommand:
sendingCommand: USER sys_tonquede
--sendCommand
readCommandResponse:
replyLineQP: 331 Username ok, send password.
--readCommandResponse
sendCommand:
sendingCommand: PASS *
--sendCommand
readCommandResponse:
replyLineQP: 530 No ftp user found.
--readCommandResponse
--Login
Failed.
--Connect_Ftp2
--SecureFtpLog

SecureFtpLog:
Connect_Ftp2:
DllDate: Jan 31 2018
SecureFtpVersion: 9.5.0.72
UnlockPrefix: PBLVND.CB1072018
Architecture: Little Endian; 64-bit
Language: Visual C++ 2015 / x64
VerboseLogging: 0
ProgressMonitoring:
enabled: no
heartbeatMs: 0
sendBufferSize: 65536
--ProgressMonitoring
ImplicitSsl: 0
AuthTls: 0
AuthSsl: 0
ftpConnect:
Hostname: ftp.tonquedec.net
Port: 21
IdleTimeoutMs: 60000
socketOptions:
SO_SNDBUF: 262144
SO_RCVBUF: 4194304
TCP_NODELAY: 1
SO_KEEPALIVE: 1
--socketOptions
readCommandResponse:
replyLineQP: 220 pyftpdlib based ftpd ready.
--readCommandResponse
initialStatus: 220
initialResponse: 220 pyftpdlib based ftpd ready.
--ftpConnect
Logging in...
Login:
sendCommand:
sendingCommand: USER sys_tonquede
--sendCommand
readCommandResponse:
replyLineQP: 331 Username ok, send password.
--readCommandResponse
sendCommand:
sendingCommand: PASS *
--sendCommand
readCommandResponse:
replyLineQP: 530 No ftp user found.
--readCommandResponse
--Login
Failed.
--Connect_Ftp2
--SecureFtpLog

SecureFtpLog:
Connect_Ftp2:
DllDate: Jan 31 2018
SecureFtpVersion: 9.5.0.72
UnlockPrefix: PBLVND.CB1072018
Architecture: Little Endian; 64-bit
Language: Visual C++ 2015 / x64
VerboseLogging: 0
ProgressMonitoring:
enabled: no
heartbeatMs: 0
sendBufferSize: 65536
--ProgressMonitoring
ImplicitSsl: 0
AuthTls: 0
AuthSsl: 0
ftpConnect:
Hostname: ftp.tonquedec.net
Port: 21
IdleTimeoutMs: 60000
socketOptions:
SO_SNDBUF: 262144
SO_RCVBUF: 4194304
TCP_NODELAY: 1
SO_KEEPALIVE: 1
--socketOptions
readCommandResponse:
replyLineQP: 220 pyftpdlib based ftpd ready.
--readCommandResponse
initialStatus: 220
initialResponse: 220 pyftpdlib based ftpd ready.
--ftpConnect
Logging in...
Login:
sendCommand:
sendingCommand: USER sys_tonquede
--sendCommand
readCommandResponse:
replyLineQP: 331 Username ok, send password.
--readCommandResponse
sendCommand:
sendingCommand: PASS *
--sendCommand
readCommandResponse:
replyLineQP: 530 No ftp user found.
--readCommandResponse
--Login
Failed.
--Connect_Ftp2
--SecureFtpLog

Removing temporary files...
Publish failed!
*** END OF PUBLISH ***

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Wed Apr 28, 2021 9:11 am

I still think something is wrong in your configuration.

Please see the reply from the server:
530 No ftp user found.
Can you login with the same settings in another FTP tool?

Yves
 
 
Posts: 4
Joined: Mon Apr 26, 2021 9:02 am

Re: Intenet exception Error 12014

Post by Yves » Mon May 10, 2021 11:21 am

Hi,

When I test the FTP engine with WWB16 (Publish==>Edit==>Test)
I obtain this mressage :
Image

but when I want to publish, I obtain this message :
Image

What am I doing wrong ?
Yves

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Mon May 10, 2021 12:41 pm

Maybe your web host no longer supports standard FTP?
Most web hosts have switched to Secure FTP for better security.

mcruss
 
 
Posts: 21
Joined: Wed Dec 22, 2010 2:20 pm
Location: Texas
Contact:

Re: Intenet exception Error 12014

Post by mcruss » Mon Sep 27, 2021 3:53 pm

I have the same issue. I have two domains, both registered with the same host. One works fine, the new one gives the 12014 error message. I've checked the pw with the provider and it is fine. All parameters seem to be OK as well. I've disabled the firewall temporarily (even though it allowed the other domain to work) but still get the same error message.

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Mon Sep 27, 2021 4:01 pm

The password error is a message from the server. The software will send your password "AS IS".

Possible reasons:
- your webhost may have changed the password
- your webhost may have switched to Secure FTP (this is very common these days)
- something else may have changed on the server side

What you can try is set the FTP engine to 'winsock' (in Tools -> Options -> Publish)
If you get the same message then it's definitely a serve related issue.

mcruss
 
 
Posts: 21
Joined: Wed Dec 22, 2010 2:20 pm
Location: Texas
Contact:

Re: Intenet exception Error 12014

Post by mcruss » Mon Sep 27, 2021 6:54 pm

I tried 'winsock' with no luck.
I've researched all the other possible reasons:
password reset and verified with server, no luck
firewall disabled for publishing, no luck
FTP changed to Secure, no luck

OK, thanks for responding anyway.

User avatar
Pablo
 
Posts: 15145
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Intenet exception Error 12014

Post by Pablo » Mon Sep 27, 2021 7:56 pm

Can you login to the server with the same settings in another FTP tool? For example, with FileZilla?
What is the error message when you use winsock?

Post Reply