Asset Manager - Listing images not actually in a page

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
code2
 
 
Posts: 54
Joined: Thu Mar 30, 2017 5:19 am

Asset Manager - Listing images not actually in a page

Post by code2 » Wed Apr 08, 2020 2:06 am

This is more of a question than an issue.

When I view the Asset Manager for my project, it show an image against the Page/Page Object.

I use a Master_Header page for placement of a common menu and a banner (a jpg) with an Embedded Page on the project's visible published pages. I also use a Master_Footer page for the much the same reason but I use SVG images in the Layout Grid on this page.

I also have a Objects_Templates page which is a Don't Publish page and an Test page is in a Don't Publish page unless I am testing something in preview or live when I don't want to change something in the project's main pages.

It is understood that the Embedded Page object (from the Header_Page) MIGHT draw across the image for pages where the Embedded Object is used on each page.

But two things appear to be an anomalous methods with the Asset Manager:

1. both Master, the Object_Templates and Test pages do not have the Embedded Page, but yet still have the Banner Image as Page Object listing.

2. SVG image objects are only listed in the Footer_Page even though they are on every published project page.

By my assumptive thinking, a page that does not contain the Embedded Page should not be listing the image.

I have gone though and checked the Style settings for each page to ensure the page does not have an image listed against it. I have found that when you had an image backgorund for a page or an object and then change the background style setting to something else, it doesn't remove the original image link. So, if you did do this, you have to go back and delete the image link line completely to prevent them from showing as an asset.

Anyway, just wondering why the Asset Manager is showing listingw for objects where I presume it shouldn't.

See linked image (the link will only be valid for 7 days as I am constantly changing my website).

Image

User avatar
Pablo
 
Posts: 23596
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Asset Manager - Listing images not actually in a page

Post by Pablo » Wed Apr 08, 2020 6:41 am

The Asset Manager will show all images, no matter if the page is marked as 'do not publish'
The page will only display the images of the page itself, it does not include images from another (embedded) page.

If you see different behavior then please include demo project so I can see all your settings.
Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

code2
 
 
Posts: 54
Joined: Thu Mar 30, 2017 5:19 am

Re: Asset Manager - Listing images not actually in a page

Post by code2 » Wed Apr 08, 2020 8:38 am

In that case, as you might see, the Asset Management is registering images that are not in the pages it says it is.

If I understood you correctly, the CoronaBanner_FireWorks.png should only be listed in the masterHeaderLGrid_Banner object.

I have removed that image from that object and set the background to solid. Saved and Previewed, it made no difference just now says file not found.

Since then the images has be put it back in the masterHeaderLGrid_Banner object and again no difference except now it is still saying File Not Found.

ADDITIONAL ISSUE FOUND:

The Asset Manager is also listing an icon image as being Orphaned, when it is fact where it should be and used as it should be as each pages Page Icon. It was there before and I removed the Icon and then put it back into the project. Same result.

Linked is the project file.

https://www.targe.com.au/Targe_20200408~1723.wbs

User avatar
Pablo
 
Posts: 23596
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Asset Manager - Listing images not actually in a page

Post by Pablo » Wed Apr 08, 2020 9:06 am

The image 'CoronaBanner_FireWorks.png' is set in the meta tags -> Open Graph, that is why it's listed for all pages.

code2
 
 
Posts: 54
Joined: Thu Mar 30, 2017 5:19 am

Re: Asset Manager - Listing images not actually in a page

Post by code2 » Wed Apr 08, 2020 9:09 am

Thank you for you troubles.

Now I know where it is coming from.

code2
 
 
Posts: 54
Joined: Thu Mar 30, 2017 5:19 am

Re: Asset Manager - Listing images not actually in a page

Post by code2 » Wed Apr 08, 2020 9:17 am

Sorry, any idea on the Orphan Files listed with the image file name: AustraliaFlagIcon004_ 256x256.png

User avatar
Pablo
 
Posts: 23596
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Asset Manager - Listing images not actually in a page

Post by Pablo » Wed Apr 08, 2020 10:11 am

You did not include the images with the project so I cannot verify this.

Also, the next time you share a project can you please remove all extensions, otherwise it will take me a lot of extra time to get the project working on my system.

Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

code2
 
 
Posts: 54
Joined: Thu Mar 30, 2017 5:19 am

Re: Asset Manager - Listing images not actually in a page

Post by code2 » Wed Apr 08, 2020 10:25 am

Sorry, I forgot the SVG files are actually from an extension.

Post Reply