Megamenu sub items background mode

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
jon@clearsitecom.com
 
 
Posts: 3
Joined: Wed Nov 25, 2020 5:29 am

Megamenu sub items background mode

Post by jon@clearsitecom.com » Wed Nov 25, 2020 6:11 am

The megamenu drop down items background is not covering text underneath the menu even though the sub items background mode is set to solid (not transparent). The sub items are mixed with anything that the drop down reaches on the page when the menu is accessed rendering an unreadable mess. Is there a solution to this problem? Thanks.

User avatar
Pablo
 
Posts: 22598
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Megamenu sub items background mode

Post by Pablo » Wed Nov 25, 2020 7:18 am

Maybe the z-order of the menu is lower than the other objects on the page?

To be able to help you,I need to see what you have done.
Do you have a demo project?

Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

jon@clearsitecom.com
 
 
Posts: 3
Joined: Wed Nov 25, 2020 5:29 am

Re: Megamenu sub items background mode

Post by jon@clearsitecom.com » Wed Nov 25, 2020 2:59 pm

Link: clearsitecom.com/test
Builder: clearsitecom.com/test/ClearSite2.wbs

User avatar
Pablo
 
Posts: 22598
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Megamenu sub items background mode

Post by Pablo » Wed Nov 25, 2020 3:12 pm

You are using a master page for the menu. In that case, the objects of the master page are always behind all other elements.
The master page is basically the 'background' of the content page.

You can prevent this by putting the menu on a page header and then set the 'stack level' to 'in front of content'.

jon@clearsitecom.com
 
 
Posts: 3
Joined: Wed Nov 25, 2020 5:29 am

Re: Megamenu sub items background mode

Post by jon@clearsitecom.com » Wed Nov 25, 2020 9:22 pm

Your solution worked very well. Thank You.

Post Reply