FlexContainer with parallax image as background not working

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
User avatar
Markus
 
 
Posts: 134
Joined: Fri Nov 23, 2018 1:06 pm
Location: Germanskow

FlexContainer with parallax image as background not working

Post by Markus » Fri Nov 27, 2020 6:54 pm

WB 15.4.5 x64

Hello everyone,

I haven't done anything with WB for some time and am now resuming an old project.

I try to display an image as parallax background in a FlexContainer.

Unfortunately the image is always static, although my opinion is that the settings are correct for parallax scrolling. The image file is 1600 pixels high and 2600 pixels wide, but this cannot be due to a too small size.

Does anyone have an idea what else I can check?
Thanks a lot.

Markus

Image

User avatar
Pablo
 
Posts: 22598
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: FlexContainer with parallax image as background not working

Post by Pablo » Fri Nov 27, 2020 9:04 pm

It seems to works for me with same settings.
To be able to help you, I need a demo project so I can see all your settings.

Related FAQ
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134

User avatar
crispy68
 
 
Posts: 1271
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: FlexContainer with parallax image as background not working

Post by crispy68 » Fri Nov 27, 2020 9:41 pm

@Pablo,
I can confirm that I'm having the same issue in WB16. I believe the issue is that it is calling the wrong ID in the function.

The function is this:

Code: Select all

<script>
$(document).ready(function()
{
   $('#FlexContainer1').parallax();
});
</script>
When it should be this:

Code: Select all

<script>
$(document).ready(function()
{
   $('#wb_FlexContainer1').parallax();
});
</script>
The wb_ is missing in the ID of the function. When this is added it works.

User avatar
Markus
 
 
Posts: 134
Joined: Fri Nov 23, 2018 1:06 pm
Location: Germanskow

Re: FlexContainer with parallax image as background not working

Post by Markus » Fri Nov 27, 2020 10:34 pm

Hello Ron,

yes you found the cause of this issue! Great.
I checked the generated html file and the wb_ prefix was missing for the flexContainer.

Dear Pablo, I didn't update to version 16 (I'm not involved enough in the business, I earn my money with Windows applications and IT services). But is there a chance to get a bugfix for WB version 15?

Markus

User avatar
crispy68
 
 
Posts: 1271
Joined: Thu Oct 23, 2014 12:43 am
Location: Acworth, GA
Contact:

Re: FlexContainer with parallax image as background not working

Post by crispy68 » Fri Nov 27, 2020 10:43 pm

@Pablo,
The culprit is when you add a maximum width to the Flex container. It is creating another <div> and the code is like such:

Code: Select all

<div id="wb_FlexContainer1">
  <div id="FlexContainer1">
  </div>
</div>
When this happens, my earlier response adding the wb_ is what needs to be changed.

User avatar
Markus
 
 
Posts: 134
Joined: Fri Nov 23, 2018 1:06 pm
Location: Germanskow

Re: FlexContainer with parallax image as background not working

Post by Markus » Sat Nov 28, 2020 9:31 am

Pablo,

do you still need a demo projekt for this issue?

Edit: anyway, here you'll find a small demoproject to reproduce the problem.

http://www.filedropper.com/issue-parallax
(You have to click on 'download this file' and then fill out a small captcha to download the file. File ist availabel till end of december 2020)

Kind Regards
Markus

User avatar
Pablo
 
Posts: 22598
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: FlexContainer with parallax image as background not working

Post by Pablo » Sat Nov 28, 2020 2:30 pm

Thanks for the information!
This will be addressed in the next update.

User avatar
Markus
 
 
Posts: 134
Joined: Fri Nov 23, 2018 1:06 pm
Location: Germanskow

Re: FlexContainer with parallax image as background not working

Post by Markus » Sat Dec 05, 2020 3:49 pm

Hello Pablo,
I read that this bug is fixed in the current update for version 16.1.

Will (such) bugs still be fixed in the past version 15 or will the development of the last version be stopped completely?

Markus

User avatar
Pablo
 
Posts: 22598
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: FlexContainer with parallax image as background not working

Post by Pablo » Sat Dec 05, 2020 4:28 pm

This was also fixed in version 15.
Note that the version number of WWB15 has not been updated because this would break backwards compatibility.

User avatar
Markus
 
 
Posts: 134
Joined: Fri Nov 23, 2018 1:06 pm
Location: Germanskow

Re: FlexContainer with parallax image as background not working

Post by Markus » Sat Dec 05, 2020 4:59 pm

Great news, Pablo.
Thank you very much. :D

Post Reply