The event (show layer) does not fire when the button is pressed

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
contextbi
 
 
Posts: 30
Joined: Tue Oct 27, 2020 2:04 pm

The event (show layer) does not fire when the button is pressed

Post by contextbi » Mon Nov 30, 2020 3:01 pm

Hello!
I created layer 35 in the program - http://joxi.ru/5mdJQvqi8d51yA. In its original state, it is hidden.
Layer settings are set: http://joxi.ru/brRWYQZcOG1nLm
I set an event on the button so that when the button is pressed, layer 35 appears http://joxi.ru/YmExN9MTMVWDYr

But on the published page, the event doesn't fire. The layer does not appear.
Please tell me what I'm doing wrong

User avatar
Pablo
 
Posts: 22600
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: The event (show layer) does not fire when the button is pressed

Post by Pablo » Mon Nov 30, 2020 3:15 pm

To be able to help you, I need a project file.

Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134


User avatar
Pablo
 
Posts: 22600
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: The event (show layer) does not fire when the button is pressed

Post by Pablo » Mon Nov 30, 2020 4:10 pm

There are two things you will need to change.
- for layer35, uncheck 'Include visibility' (see the help for more details)
- use showwitheffect, instead of 'show'
'show' toggles the 'visibility'
'showwitheffects' toggles the 'display' property.
Floating layers uses 'display:none' to hide, because otherwise it would still take up space in the layout.

If you do not want an effect then set the length of showwitheffects to 0

Also, the next time you share your project, can you please remove all elements which are not relevant to your question? That will save me a lot of time.

contextbi
 
 
Posts: 30
Joined: Tue Oct 27, 2020 2:04 pm

Re: The event (show layer) does not fire when the button is pressed

Post by contextbi » Mon Nov 30, 2020 4:48 pm

Thank you for your reply!
Okay, next time I'll remove the non-relevant items. Thank you for your patience

Post Reply