Image not centering in Layout Grid

All WYSIWYG Web Builder support issues that are not covered in the forums below.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/getting_started.html
WYSIWYG Web Builder FAQ
Post Reply
User avatar
roygore
 
 
Posts: 91
Joined: Wed Mar 25, 2020 6:34 pm
Location: United Kingdom

Image not centering in Layout Grid

Post by roygore » Thu May 13, 2021 8:49 am

I have one page in my project with images and shapes in Layout Grids which will not center on the page!

I have other pages in the same project with images that do center on the page without any problems and I've doubled checked and compared the setup with the page that doesn't work but can't find the problem.

I probably have something setup incorrectly but can't find what it is, so need some help please.

Here is a link to download the wwb file and associates files: https://up.labstack.com/MR0Ob3ey See the 'heritage-trail' page.

I've removed all the uncessary pages in the project to reduce the size.

The problem page is the'heritage-trail' and the problem elements are:
- the 2 cloud shapes near the top of the page
- the 'Heritage Trail' poster image
- the 'SUPERimpose' image
- the 'Google Play' and 'Apple' images near the bottom of the page

Can anyone help and tell me what I am doing wrong?

All help will be greatly appreciated.

Roy

User avatar
Pablo
 
Posts: 23930
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Image not centering in Layout Grid

Post by Pablo » Thu May 13, 2021 10:23 am

I have found the folliiwng issues:

1. The default view (desktop) should be the widest view. So, you should remove the 1024px breakpoint or make the default view wider.

2. The breakpoints in pages should be the same as in the master pagea.

3. the page alignment should not be set the 'center page in browser'. This option is only for fixed/absolute layouts.

User avatar
roygore
 
 
Posts: 91
Joined: Wed Mar 25, 2020 6:34 pm
Location: United Kingdom

Re: Image not centering in Layout Grid

Post by roygore » Thu May 13, 2021 11:41 am

Thank Pablo for your reply.

1. Don't know how the Default page size became 980! I've checked everypage in the project and found several page widths set to 980 as well. I've set the Default on all pages to 1280.

2. I've also been through the entire project and checked that the breakpoints are the same in all pages and match the Master page.

3. I've tried setting the Page Alignment to both 'Center horizontally' and 'Do not center this page'. What should the Page Alignment be set to?

These changes seem to have fixed the problem in the Default breakpoint but not in other breakpoints. Should I do something different in the other breakpoints?
_____________________________________

After posting this cry for help, I discovered that if I put the shapes and the images in a 'Flex container' inside the Layout Grid, then it all worked perfectly including in different breakpoints.

Any idea why this should work?

Roy

User avatar
Pablo
 
Posts: 23930
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: Image not centering in Layout Grid

Post by Pablo » Thu May 13, 2021 1:08 pm

1. In the project you have shared, the page width of 'heritage-trail' is 970, it must be 1280

2. Not in the project you have shared.

3. It must be set to 'Do not center this page'

If that does not help, then go to each breakpoint and:
- select the column
- set the alignment to left and then to center
- do this for all columns

User avatar
roygore
 
 
Posts: 91
Joined: Wed Mar 25, 2020 6:34 pm
Location: United Kingdom

Re: Image not centering in Layout Grid

Post by roygore » Fri May 14, 2021 8:45 am

Thanks Pablo for all your help.

I have another problem in the same project with the Panel Menu for smaller breakpoints, but I will start another post for that.

Thanks
Roy

Post Reply